Ticket #3914 (closed defect: wontfix)

Opened 3 years ago

Last modified 3 years ago

Citations should be language dependent

Reported by: sf03r@… Owned by: sf03r@…
Priority: unset Milestone: EPrints 3.2.x (general bugs/features for 3.2)
Component: - Version:
Severity: normal Keywords:
Cc:

Description

All English words should be removed from citations and phrased.

I personally think that citations should be under lang/{en,fr,de}/ cause it's kinda hard to match different language structures by using phrases e.g.:

<print expr="thesis_type"/> thesis thesis

wouldn't work in French, as it needs something like:

these <print expr="thesis_type"/>

Change History

Changed 3 years ago by sf03r@…

  • owner set to sf03r@…

I'll try to update the citations as I'm developing a repo for a French Uni.

Changed 3 years ago by cjg

I thought about his long ago, but I think it would be a nightmare of citation files getting out of sync with each other. You can use pins in phrases to move the ordering around between languages.

Changed 3 years ago by sf03r@…

  • status changed from new to closed
  • resolution set to wontfix

duplicate of #3177

Note: See TracTickets for help on using tickets.