Ticket #3915 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Access records not being created by LogHandler

Reported by: tmb Owned by:
Priority: Customer Report Milestone: 3.2.5
Component: - Version: 3.2
Severity: normal Keywords: Concordia
Cc:

Description (last modified by tmb) (diff)

Client reported that no entries are being created in their access table. Investigation revealed that that $repository is never defined in Apache::LogHandler::_create_access, so the access entry is never written.

sub _create_access
{
        my( $r, $epdata ) = @_;

        my $repository = $EPrints::HANDLE->current_repository;
        if( !defined $repository )
        {
                return DECLINED;
        }

Could not reproduce on local fresh install of 3.2.4 (Fedora).

However could reproduce on demoprints (note symptom - 0 records in access table).

Noted that both client and demoprints run on Ubuntu, don't know if this could be a factor.

Change History

Changed 3 years ago by tmb

  • description modified (diff)

Changed 3 years ago by tdb01r

  • status changed from new to closed
  • resolution set to fixed

Resolved by r5964, r5963.

Changed 3 years ago by tdb01r

  • milestone changed from EPrints 3.2.x (general bugs/features for 3.2) to 3.2.5
Note: See TracTickets for help on using tickets.